Zoom Integration Outage — Live Class Auto-Start and Recordings Affected

Incident Report for Marvelous

Resolved

The Zoom integration is now fully restored: live class auto-start and recording uploads are working normally again. Note: some recordings from classes held during the outage may not have auto-uploaded, and you'll need to manually fetch those recordings from your Zoom account and upload into Marvelous. We're sorry for the disruption and thank you for your patience.
Posted May 11, 2026 - 16:46 PDT

Update

Monitoring: Zoom has restored our app and webhook events are being delivered again. However, there is a backlog of webhook events that Zoom is now processing, which means some events (live class start notifications, recording uploads) may arrive with delays for the next several hours.

If you have a class starting soon, we recommend continuing to send your Zoom meeting link directly to students from your Zoom account as a precaution. We'll mark this incident Resolved once webhook delivery returns to normal latency.
Posted May 11, 2026 - 13:00 PDT

Monitoring

A fix has been implemented and we are monitoring results.
Posted May 11, 2026 - 12:55 PDT

Identified

We're aware that the Zoom integration is currently disrupted. Live classes are not auto-starting, and class recordings are not auto-uploading to your media library.

Cause: Zoom has disabled our app without notice (looks like an internal update in their system broke our app connection). We're in active contact with Zoom's support team, and this is our team's top priority.

Workaround for your classes, until further notice:
• Send your Zoom meeting link directly to students from your Zoom account so they can join
• After class, download recordings from Zoom and upload them manually to your media library

We're very sorry for the disruption and the lack of advance notice.

We'll post updates here as we have them.
Posted May 11, 2026 - 10:56 PDT
This incident affected: Zoom Cloud Recording, Zoom Zoom Meetings, and Zoom Zoom Video Webinars.